Java no responde en Firefox 42.0

Desde que Firefox se actualizó a la versión 42.0 he notado como algunas páginas web que utilizan applets de java han dejado de funcionar. A los pocos segundos de cargar la página se muestra el siguiente mensaje.

Java(TM) Platform SE 8 U65 puede estar ocupado o puede haber dejado de responder. Puede detener el plugin ahora o puede continuar para ver si el plugin completa su tarea.

En la web de Java se comentan varias posibles soluciones, aunque el método más simple y el que recomiendan es el siguiente:

  1. Abrir Firefox.
  2. En la barra de direcciones escribir about:config para acceder a la zona de configuración.
  3. Firefox nos avisará de que estamos intentando acceder a una zona “Hostil para manazas”. Aceptamos para poder continuar.
  4. Pulsar el botón derecho del ratón en cualquier parte de la página y seleccionar Nuevo -> sí/no (boolean).
  5. Introducimos una nueva preferencia llamada dom.ipc.plugins.java.enabled y seleccionamos como valor false.

Después de seguir estos sencillos pasos he vuelto a poder ejecutar applets java en mi navegador y parece que todo funciona como antes. Espero que para las próximas versiones de Firefox se solucione el problema y no sea necesario tocar la configuración del navegador.

17 comentarios en “Java no responde en Firefox 42.0”

  1. Hola! Hace un mes tenía este error, seguí tus pasos y se arregló el problema! (antes de ver tu post probé otras soluciones que no daban en el clavo..) Gracias por tu aporte, me sirvió mucho!
    Ahora ha vuelto a aparecer el mismo error en la misma web (usando un certificado digital) y ya no se que hacer!
    Odio java, odio firefox y odio los certificados digitales.

  2. no sirvió esta recomendación, tengo win 10 y Firefox 43.0, me sale el mismo error cuando se va a utilizar para certificados digitales, que otra posibilidad de corrección hay? favor utilizar la dirección de mi e-mail para responder, gracias

    1. Hola Fercho,
      Acabo de probar el acceso mediante certificado digital con Firefox 43.0.4 y Windows 7 y no he tenido ningún problema. Puede que el problema no sea de Firefox ni de Java, sino de la implementación que haga esa web del acceso mediante certificado.
      Cuando tenga un rato lo probaré más detenidamente a ver si me falla con otra configuración distinta.

      Saludos.

      1. Hola Enrikus, mil gracias por tener en cuenta mi comentario. Veo que probaste con Windows 7, el error me salió con Firefox 43.0.4 pero con Windows 10 como dije anteriormente, será algo de win 10?.

  3. Hola que tal, eh seguido los pasos anteriores pero sigue sin funcionar y me sigue apareciendo la misma leyenda “Java(TM) Platform SE 8 U65 puede estar ocupado o puede haber dejado de responder. Puede detener el plugin ahora o puede continuar para ver si el plugin completa su tarea” cabe mencionar que todo empezo por la nueva actualizacion de Firefox 44

  4. Hola! A mí me ocurre lo mismo que a Fercho, cuando voy a usar el certificado digital me pone ese mensaje de que Java puede estar ocupado o puede haber dejado de responder y no soy capaz de solucinarlo de ninguna manera, ni siquiera realizando tus pasos. Me ha empezado desde que he actualizado a la versión 8 U71. Yo tengo Windows 8.1. Os agradecería muchísimo vuestra ayuda

    1. Hola Fernando,

      A mí también se me han empezado a bloquear de nuevo los Applets de Java en el navegador. Esta “solución” solo sirve para las versiones 42 y 43 de Firefox. Con la versión 44 vuelve a fallar…

      Por lo que he leído Firefox, al igual que Chrome, está dejando de dar soporte a Java por sus problemas de seguridad. Ahora mismo el único navegador con el que me siguen funcionando los Applets es con Internet Explorer.

      1. Hola Enrikus,
        Disculpa que configuración debes realizar para trabajar con Internet Explorer y te muestre todo correctamente? En caso particular de las declaraciones he tenido problemas ya que en la ultima pantalla se queda en color gris, esto en IE. Por esta razón opte por utilizar Firefox, con este navegador también la primera vez se quedo en color gris, pero en la parte superior viene la opción que dice permitir ejecutar plugin y la pagina se carga correctamente. Estas opciones no las he podido localizar en Internet Explorer.
        La verdad quisiera trabajar en IE ya que en Firefox comencé a tener los mismos problemas tuyos y no he encontrado solución.

        1. Hola Wilberth,
          Si no recuerdo mal en Internet Explorer 10 y 11 primero te aparece un pop-up amarillo en la parte de abajo del navegador dónde te pregunta si quieres permitir la ejecución de Java en el navegador. Una vez permites la ejecución ya aparecen las típicas ventanas de Java dónde te preguntan si quieres permitir la ejecución del applet.
          Saludos.

  5. tengo el mismo problema, en W10 con firefox 8 U73 no deja buscar el certificado, se traba y termina por cerrarse la aplicación, crar el booleano funciona en W7 y XP pero no en W10, al final me aparece este error:

    Error: Error calling method on NPObject!

    alguien tiene una solución? se los agradeceré

    1. Es posible que sea muy tarde, pero yo acabo de actualizar Java y tenía (y aún tengo) este problema, pero me dí cuenta que es que la ventana de java para buscar el certificado se va al fondo, entonces lo que hago es, antes de dar click en el botón “Buscar”, minimizar todo a la barra de tareas, hacer la ventana de firefox hacia el lado derecho, pues la ventana se creará en el lado izquierdo, ahora si le doy a “Buscar” y se abre la ventana en el lado superior izquierdo, se bloquea y hay que darle al cuadro de dialogo que quieres que java continue, y despues de esto ya podemos usar la ventana que aparece y que no estará detras de firefox. No es solución, pero en algo ayudará

  6. hola tengo el mismo error, uso windows 8.1 y firefox 46.0.1 les agradeceria me ayudaran no puedo ni accesar a la nefasta pagina del sat!

    1. Por ahora la única forma de poder ejecutar applets de Java en el navegador sin problemas es utilizar Internet Explorer 11 o descargar una versión de Firefox anterior a la 42.0.

  7. Hola a todos:

    Lo que a mí me funcionó para poder firmar con certificado digital fue:
    – instalar una versión de Mozilla muy anterior a la que tenía (instalé la que recomienda Wilberth un par de comentarios más arriba, https://download.mozilla.org/?product=firefox-38.8.0esr-SSL&os=win&lang=es-MX)
    – hice lo siguiente: “En una pestaña nueva de Firefox escribimos en la barra de direcciones: “about:config”. El navegador nos advierte literalmente que es una ¡Zona hostil para manazas!. Como seguro que no eres ningún manazas y lo que te propongo es muy sencillo, simplemente pulsa el botón “¡Tendré cuidado, lo prometo!”. En la ventana que aparece a continuación, escribimos en la casilla de Filtro la palabra “signed”, y encontraremos “signed.applets.codebase_principal_support”. Veremos que el valor está establecido a “false”, que es lo que nos impide continuar. Sólo hay que hacer doble clic para cambiarlo a “true”, y entonces ya si podremos permitir que se ejecute el script que nos permitirá seleccionar el fichero e importarlo al modelo telemático.” – encontré la info aquí http://www.redmamba.es/declaraciones-telematicas-aeat-firefox-2011.

    Yo tengo windows 10.

    ¡ánimo a todos!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *