Error al iniciar VirtualBox: The device helper structure version has changed

Un error bastante común al iniciar VirtualBox en Linux es el error “The device helper structure version has changed”. Este error se deve a que VirtualBox se ha actualizado, normalmente de forma automática, y el Extension Pack que tenemos instalado se ha quedado obsoleto y es necesario actualizarlo manualmente.

Error VirtualBox

Lo primero que tenemos que hacer es comprobar la versión actual de nuestro VirtualBox. Para ello vamos a Ayuda -> Acerca de VirtualBox y se nos abrirá una ventana como la siguiente donde veremos la versión en la parte inferior derecha. En mi caso la versión de VirtualBox que tengo instalada es la 5.0.18.

Version VirtualBox

El siguiente paso es ir al directorio de descargas de VirtualBox, buscar nuestra versión en el listado y dentro tendremos el Extensión Pack que deberemos descargar.

Extension Pack VirtualBox

El último paso es ir a Archivo -> Preferencias y en el menú de la izquierda seleccionar la opción Extensiones. Eliminamos el Extensión Pack antiguo (en mi caso la versión 5.0.14) y añadimos el Extension Pack actualizado (versión 5.0.18) que nos acabamos de descargar.

Preferencias VirtualBox

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *